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AZ Icon Edit Packing List

AZ Icon Edit is distributed with the following files.    

AZICONED.EXE
AZICONED.HLP
READ.ME
LICENSE.DOC
ORDER.FRM

If you have received a copy of this program that does not include all of these files,    then you
have received an incomplete package.    Please contact us at the following address for more 
information.

AZ Computer Innovations
Post Office Box 10514
Glendale, Arizona        85318



AZ Icon Edit License Agreement

This document and the program files AZICONED.EXE & AZICONED.HLP ("the software") are 
copyrighted by AZ Computer Innovations. You are granted a limited license to use and 
evaluate the software for a period of 21 days. You may also make copies of the software to 
give to others for their evaluation, provided the following restrictions are met:

o      Only unregistered copies of the software may be distributed. 

o      The software and the    files READ.ME, LICENSE.DOC and ORDER.FRM shall be supplied
in their original unmodified form.

o      The software may not be included, or bundled, with other goods or services. 
Exceptions may be granted upon written request only.

o      No fee may be charged for the software.

o      Anyone wishing to charge a fee for the distribution of AZ Icon Edit must have the 
written permission of the copyright owner, without which, the distributor is guilty of a 
copyright violation. For distributors already recognized by the Association of Shareware
Professionals, this written permission is not required.

If you make use of the software after the 21 trial day period, you are obligated to pay a 
registration fee of $20.00 in U.S. funds to:

AZ Computer Innovations
Post Office Box 10514
Glendale, Arizona    85318

Upon receipt of your registration fee, AZ Computer Innovations will mail you a registered 
version of AZ Icon Edit and grant you a license to use it on any one computer at any one 
time. You must treat this registered version of AZ Icon Edit just like a book.    An example is 
that AZ Icon Edit may be used by any number of people and may be freely moved from one 
computer location to another, so long as there is no possibility of it being used at one 
location while it's being used at another.    Just as a book cannot be read by two different 
persons at the same time. 



Warranty Disclaimer

AZ Icon Edit is provided "as is". There is no warranty of any kind.    The copyright owner will 
not be held liable for any damages, including any lost profit or other incidental or 
consequential damages arising out of or inability to use AZ Icon Edit.    By using AZ Icon Edit,
you agree to this.



Creating and Modifying Icons

o        Creating a new Icon

A new icon may be created simply by using any of AZ Icon Edit's tools to draw the desired
image on the edit window.    When the image has been completed, it may be saved to a 
file on disk by using the command on the File menu.

o        Modifying an existing icon

An existing icon may be loaded into the editor by using the File Open menu item.    It may 
then be modified and saved to the same file on disk or saved to a new file by using the 
commands on the File menu.



Selecting Colors

AZ Icon Edit allows for two colors to be currently selected for drawing.    The currently 
selected colors are indicated by the left and right color windows that are located just above 
the color palette.    The left and right current color window corresponds to the left and right 
mouse button.    New colors may be selected by positioning the mouse cursor over the desire
color in the color palette and clicking the left or right mouse button.    

There is also a third color window labeled "Screen" that is located right above the left and 
right current color windows.    It is used to show the color that has been selected to indicate 
transparency.      Whenever it is selected (indicated by a heavier black border), any drawing 
that is done will take on the color of the screen background of the application that the icon is
used in.    This will create an    illusion of transparency.

Either the left and right current color or the Screen color may be selected for drawing with 
any of the tools, but not at the same time.    The one that is currently selected for drawing 
will be indicated by a heavier black border around the color window(s).    The desired color 
window may be selected by positioning the mouse cursor in that window and clicking.



Selecting a Window Size

The sizes of all elements in AZ Icon Edit's display are selected automatically whenever the 
main window is resized.    The size of the sample image window and the screen color border 
around the sample image will always remain the same.

When the program is terminated, the current window size and position will be saved in the 
file "AZICONED.INI".    This file is created when AZ Icon Edit is run for the first time.    The file 
is located in the same directory as AZ Icon Edit.    The file is used to save user preferences, 
so that when the program is restarted, the window size and position will be restored to the 
same as they were in the previous session.



Menu Items

File Menu                        
Edit Menu                       
Image Menu                    
Options Menu  



Drawing    and Editing Tools

Straight Line Drawing               
Pencil                                
Fill Tool                            
Line Size                                      
Select Box                                    
Image Shifting                            
Capture                                        
Rectangles                                   
Rounded Rectangles                  
Ellipses                                        



File Menu Items

The File menu includes commands that enable you to open and save files, establish a new 
icon, and to exit.

For more information, select one of the File menu topics listed below.

New                                  
Open                                
Save                                 
Save As                           
Exit                                   



Edit Menu Items

The Edit menu includes commands that enable you to undo an editing operation, copy/cut 
selected portions of the current icon to and from the Clipboard, and capture an image from 
anywhere on the screen.

For more information, select one of the Edit menu topics listed below.

Undo                    
Capture              
Cut                      
Copy                    
Paste                   



Image Menu Items

The image menu includes commands that enable you to flip the image vertically or 
horizontally, rotate the image 90 degrees, clear the current image, and restore the image to 
the same condition as existed when it was first loaded.

For more information, select one of the Image menu topics listed below.

Flip Horz                         
Flip Vert                          
Rotate Left         
Clear                                 
Restore                           
 



Options Menu Items

The    Options menu includes commands that enable you to set the line thickness of the 
drawing pencil and the border thickness of some of the drawing tools.

For more information, select one of the Options menu topics listed below.

Thin Line                                      
Medium Line      
Thick Line                       



File New Command

File New is used to clear the current icon and open a new untitled icon.

o        If the current icon has already been saved or it is unchanged, the new icon is created 
immediately.

o        If changes have been made to the current icon and it has not been saved, a Prompt for 
Save dialog box will be opened to ask whether you want to save the changes made to the
current icon.



Prompt for Save Dialog Box

If changes have been made to the current icon and it has not been saved, a dialog box will 
be opened to ask whether you want to save the changes made to the current icon.

o        Click Yes to save the changes.    If the current icon is untitled, the File Save As dialog 
box will be opened to allow you to name the icon.

o        Click No to discard the changes.

o        Click Cancel to cancel the command.



File Open Command

File Open is used to load an existing icon into the editor.

o        If the current icon has already been saved or it is unchanged,    the File Open dialog box 
will be opened.

o        Select the drive/directory you wish to load the icon file from by double clicking on the 
desired drive/directory in the Directory List Box.

o        Select the icon you wish to load by double clicking on the desired icon file in the Files 
List Box.    You may also load an icon file by selecting it and clicking on the OK button.

o        If changes have been made to the current icon and it has not been saved, a Prompt for 
Save dialog box will be opened to ask whether you want to save the changes made to the
current icon.



File Save Command

File Save is used to save the current icon using its original file name.

If the current icon is untitled, the File Save As dialog box will be opened to allow you the 
opportunity to name the icon.



File Save As Command

FileSave As is used to save the current icon under a different name.

o        Select the drive/directory you wish to save the icon file to by double clicking on the 
desired drive/directory in the Directory list box.

o        Type the name of the icon file you wish to save to into the Filename edit box or select 
an existing icon file by double clicking on the file in the Files list box.    



File Exit Command

File Exit is used to exit the program

If changes have been made to the current icon and it has not been saved, a Prompt for Save 
dialog box will be opened to ask whether you want to save the changes made to the current 
icon.



Edit Undo Command

Edit Undo is used to reverse the effects of the previous editing operation.    It may be used 
with all of the drawing tools and the tools and commands listed below. 

Flip Horz                         
Flip Vert                          
Rotate Left         
Clear                                 
Cut                                   
Copy                                 
Paste                                
Capture                           



Edit Capture

Edit Capture permits you to select a 32x32 pixel area from anywhere on the screen and 
copy it to the current icon.    When Capture is selected, the cursor changes to a select box 
which is used to outline the area to be captured.    The area inside the select box is 
continuously displayed in the Edit Window.    The image is captured by pressing and releasing
either mouse button.

You may also use the arrow keys to zero in on the area you want to capture and then use the
return key to capture the image.



EDIT Cut Command

Edit Cut is used to remove the area outlined by the select box and save it to the Clipboard.  
The cut information may be retrieved with the Edit Paste Command.    Cut may be used to 
move a portion of the image from one place to another.

The image that is saved to the Clipboard will remain there until replaced by another 
cut/copy.    It may also be accessed by other applications.



Edit Copy Command

Edit Copy is used to copy the area outlined by the select box to the Clipboard.    The copy 
information may be retrieved with the Edit Paste Command.    Copy may be used to duplicate
a portion of the image.

The image that is copied to the Clipboard will remain there until replaced by another 
cut/copy.    It may also be accessed by other applications.



Edit Paste Command

Edit Paste is used to retrieve the contents of the Clipboard into the area outlined by the 
select box.    If the image saved on the Clipboard does not have the same dimensions as the 
select box, a dialog box will be opened to allow you to select one of the two options listed 
below.

o        Stretch/shrink Clipboard bitmap?

Select this option if you wish the bitmap on the Clipboard to be stretched or shrunk to the
size of the select box.

o        Clip Clipboard bitmap?

Select this option if you wish the bitmap on the Clipboard to be copied as is to the select 
box.    It will only be clipped if it is necessary to fit inside of the select box.

When you have selected the desired option, click on OK.    You may also cancel the paste 
operation by clicking on Cancel.



Image Flip Horizontal

Flip Horizontal is used to reverse the current image horizontally.    Left becomes right, and 
right becomes left.    The effects of Flip Horizontal may be reversed with the Undo    
command or by doing another Flip Horizontal.



Image Flip Vertical

Flip Vertical is used to reverse the current image vertically.    Top becomes bottom, and 
bottom becomes top.    The effects of Flip Vertical may be reversed with the Undo    command
or by doing another Flip Vertical.



Image Rotate Left

Rotate Left is used to rotate the current image 90 degrees to the left. The effects of Rotate 
Left may be reversed with the Undo    command or by doing three more Rotate Lefts.



Image Clear Command

Image Clear is used to completely erase the current image.    If you change your mind after 
selecting Clear, the previous image may be returned with the Undo    command.



Image Restore Command

Image Restore is used to restore the image to the same as it was when it was first loaded.  
It may only be used with icons that were loaded from a file.    If you change your mind after 
selecting Restore, the previous image may be returned with the Undo    command.



Options Thin Line Command

The Thin Line command sets the line drawing thickness for the following tools to the values
specified.

o        Pencil Tool 1x1 pixel
o        Hollow Rectangle 1x1 pixel
o        Hollow Ellipse 1x1 pixel
o        Hollow Rounded Rectangle 1x1 pixel



Options Medium Line Command

The Medium Line command sets the line drawing thickness for the following tools to the 
values specified.

o        Pencil Tool 3x3 pixels
o        Hollow Rectangle 2x2 pixels
o        Hollow Ellipse 2x2 pixels
o        Hollow Rounded Rectangle 2x2 pixels



Options Thick Line Command

The Thick Line command sets the line drawing thickness for the following tools to the 
values specified.

o        Pencil Tool 5x5 pixels
o        Hollow Rectangle 3x3 pixels
o        Hollow Ellipse 3x3 pixels
o        Hollow Rounded Rectangle 3x3 pixels



Straight Line Drawing Tools

This tool is used to draw a straight line from any point on the image to any other point.    The
color that is used for drawing is determined by which mouse button (left or right) is used. 
The thickness of the line is controlled by the line thickness settings located on the Options 
menu.

This tool is used to draw a straight line along the 0, 45, 90, 135, or 180 degree axes.    The 
color that is used for drawing is determined by which mouse button (left or right) is used. 
The thickness of the line is controlled by the line thickness settings located on the Options 
menu.

When either of the straight line drawing tools have been selected, the cursor will change to 
a cross hair whenever it is over the edit window.



Pencil

The pencil tool is used to draw free hand lines and shapes.    The color that is used for 
drawing is determined by which mouse button (left or right) is used.    The thickness of the 
line is controlled by the line thickness settings located on the Options menu.

When the pencil tool has been selected, the cursor will change to a pencil whenever it is 
over the edit window.    There are three different sizes of pencil cursors, depending on what 
line thickness has been selected.



Select Box

The select box is used to outline an area of the image that is to either to be cut or copied to 
the clipboard or receive an image that is pasted from the clipboard.

When the Select Box tool has been selected, the cursor will change to a cross hair whenever 
it is over the edit window.



Fill Tool

The fill tool is used to fill large areas with a single color.    The color used for filling is 
determined by which mouse button (left or right) is used.    The area that is filled is 
determined by the color of the starting pixel.    All pixels that are adjacent to the starting 
pixel and are the same color will be filled.

When the Fill tool has been selected, the cursor will change to a hypo whenever it is over the
edit window.



Line Size Tool

This tool is used to set the line thickness of the drawing pencil and the border thickness of 
some of the drawing tools.    It is a three way toggle that selects eitherThin Line ,    Medium 
Line , or      Thick Line .



Image Shifting Tools

Flip Horizontal is used to reverse the current image horizontally.    Left becomes right, and 
right becomes left.    The effects of Flip Horizontal may be reversed with the Undo    
command or by doing another Flip Horizontal.

Flip Vertical is used to reverse the current image vertically.    Top becomes bottom, and 
bottom becomes top.    The effects of Flip Vertical may be reversed with the Undo    command
or by doing another Flip Vertical.

Rotate Left is used to rotate the current image 90 degrees to the left. The effects of Rotate 
Left may be reversed with the Undo    command or by doing three more Rotate Lefts.



Capture Tool

Capture permits you to select a 32x32 pixel area from anywhere on the screen and copy it 
to the current icon.    When Capture is selected, the cursor changes to a select box which is 
used to outline the area to be captured.    The area inside the select box is continuously 
displayed in the Edit Window.    The image is captured by pressing and releasing either 
mouse button.

You may also use the arrow keys to zero in on the area you want to capture and then use the
return key to capture the image.



Rectangles

This tool is used to draw hollow rectangles.    The color used for the border is determined by 
which mouse button is used (left or right).    Once the rectangle has been drawn, you may 
leave it as is, or fill it with a different color using the Fill tool.

This tool is used to draw solid rectangles.    The color used for the rectangle is determined by
which mouse button is used (left or right). 

When either of the Rectangle drawing tools have been selected, the cursor will change to a 
cross hair whenever it is over the edit window.



Rounded Rectangles

This tool is used to draw hollow rectangles with rounded corners.    The color used for the 
border is determined by which mouse button is used (left or right).    Once the rectangle has 
been drawn, you may leave it as is, or fill it with a different color using the Fill tool.

This tool is used to draw solid rectangles with rounded corners.    The color used for the 
rounded rectangle is determined by which mouse button is used (left or right). 

When either of the Rounded Rectangle drawing tools have been selected, the cursor will 
change to a cross hair whenever it is over the edit window.



Ellipses

This tool is used to draw hollow ellipses.    The color used for the border is determined by 
which mouse button is used (left or right).    Once the ellipse has been drawn, you may leave 
it as is, or fill it with a different color using the Fill tool.

This tool is used to draw solid ellipses.    The color used for the ellipse is determined by which
mouse button is used (left or right). 

When either of the Ellipse drawing tools have been selected, the cursor will change to a 
cross hair whenever it is over the edit window.






